Devuan ou Linux comme il se doit

Le choix de la liberté Historique Dans cet article, je clamais mon ras le bol sur les controverses qui gangrénaient de plus en plus la philosophie du hacking – au sens originel – que l’on trouvait au sein des communautés linuxiennes. J’avais décidé de ne plus utiliser, volontairement, un de ces systèmes et de confier mes machines au vénérable système d’exploitation qui pique, à savoir OpenBSD. Toutefois, et oui j’y arrive. »

OpenBSD et le trackpoint du thinkpad

Je possède un thinkpad X200, ce qui signifie que je n’ai pas de touchpad. De plus, je n’utilise pas de souris par choix. Mais bon, pour scroller des fois c’est quand même pénible :P Bref, un thinkpad possède un trackpoint, c’est à dire la ‘tite boule rouge sur la photo. De plus, sous la barre d’espace se situent 3 boutons qui sont équivalents au trois boutons d’une souris classique. Il est possible en cliquant sur le bouton du milieu et en jouant du trackpoint, de scroller très facilement. »

Tchuss Linux, ola OpenBSD

Ras le bol Je ne le cache plus, je me sens de moins en moins à l’aise avec Linux. Systemd et Cie y sont sûrement pour beaucoup. Quand on voit que même Debian change son init sans trop tenir compte de l’avis de sa base, quand on voit les petites guerres stériles dûes aux divergences d’opinions qui fragmentent les communautés, et, surtout quand on se dit que malgré la plénitude de ses distributions, Linux est en train de s’uniformiser et de s’éloigner de plus en plus d’une philosophie UNIX et d’une certaine philosophie HACKER que j’apprécie. »

kimsufi, freeBSD 9.2 et pkgng.

J’ai eu la chance de recevoir un des serveurs les plus convoités de l’ été, à savoir le kimsufi ks 2G. Serveur à base d’atom 64bits, 2Go de RAM, 500 Go de stockage et moins de 5€ par mois, ça ne vaut pas le coup de se priver ;). Au niveau du système d’exploitation, OVH est resté bloqué sur FreeBSD 9.1. Pour ceux qui seraient frileux à cause de la mise à jour, ceci devrait vous rassurer. »

Utiliser emacs 24 sur elementaryOS luna

ElementaryOS “Luna” utilise Ubuntu 12.04 LTS (“The Precise Pangolin”) comme fondation. La version d’Emacs disponible est donc la version 23.3. 2 choix s’offrent à nous si on souhaite utilser la version 24 et ses nombreuses améliorations. À savoir la compilation à partir des sources où l’utilisation d’un paquet gentiment proposé par quelqu’un. Et c’est là qu’on remarque l’utilité et la puissance des PPA(Personal Package Archives). Ces derniers sont des dépôts de paquets de personnes comme vous et moi, et ceci est à tout de même à prendre en considération avant d’en utiliser un. »