Utiliser emacs 24 sur elementaryOS luna

ElementaryOS “Luna” utilise Ubuntu 12.04 LTS (“The Precise Pangolin”) comme fondation. La version d’Emacs disponible est donc la version 23.3.

2 choix s’offrent à nous si on souhaite utilser la version 24 et ses nombreuses améliorations. À savoir la compilation à partir des sources où l’utilisation d’un paquet gentiment proposé par quelqu’un.

Et c’est là qu’on remarque l’utilité et la puissance des PPA(Personal Package Archives). Ces derniers sont des dépôts de paquets de personnes comme vous et moi, et ceci est à tout de même à prendre en considération avant d’en utiliser un.

Bref, le service est proposé par la forge Launchpad. Celui qui désire mettre un paquet à disposition fournit le code source à la forge qui se chargera de compiler les paquets pour les diverses versions d’Ubuntu.

Dans le cas d’Emacs, un utilisateur, Mr Damien Cassou fournit les dernières versions à savoir, à ce jour, la version stable 24.3.1 et la version en cours de développement (“snapshot”).

Procédure pour une installation bien propre

Désinstallation d’emacs 23 (si précédemment installé;)) :

$ sudo apt-get update
$ sudo apt-get install
$ sudo apt-get purge emacs23 emacs23-bin-common emacs23-common emacs23-el emacs23-nox emacs23-lucid

Ajout du PPA au gestionnaire de paquet :

$ sudo add-apt-repository ppa:cassou/emacs$ sudo apt-get update

Installation d’emacs 24 :

$ sudo apt-get install emacs24 emacs24-el emacs24-common-non-dfsg

Et voilou, merci Damien !